42 lines
898 B
Nix
42 lines
898 B
Nix
{
|
|
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
|
|
outputs =
|
|
{ nixpkgs, ... }:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
devShells.${system}.default = pkgs.mkShell {
|
|
buildInputs = with pkgs; [
|
|
bashInteractive
|
|
entr
|
|
lowdown
|
|
tailwindcss
|
|
];
|
|
};
|
|
|
|
packages.${system} = with pkgs; {
|
|
ssg = mkDerivation {
|
|
name = "ssg";
|
|
|
|
src = fetchurl {
|
|
url = "https://romanzolotarev.com/bin/ssg";
|
|
sha256 = "OgqH4ZQ47EM25ubEpum6v38Tl76hQPh7aZ6VRQcbd2M=";
|
|
};
|
|
|
|
dontUnpack = true;
|
|
|
|
installPhase = ''
|
|
mkdir -p $out/bin
|
|
cp $src $out/bin/ssg
|
|
chmod +x $out/bin/ssg
|
|
'';
|
|
};
|
|
};
|
|
|
|
formatter.${system} = pkgs.nixfmt-rfc-style;
|
|
};
|
|
}
|