22 lines
438 B
Nix
22 lines
438 B
Nix
{
|
|
inputs.nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
|
|
|
|
outputs =
|
|
{ nixpkgs, ... }:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = import nixpkgs { inherit system; };
|
|
in
|
|
{
|
|
devShells.${system}.default =
|
|
with pkgs;
|
|
mkShell {
|
|
buildInputs = [
|
|
php83
|
|
php83Packages.composer
|
|
];
|
|
};
|
|
|
|
formatters.${system} = pkgs.nixfmt-rfc-style;
|
|
};
|
|
}
|