dotfiles/nix/lib/shared/scripts/_timer.nix
Oliver Davies 69a397e624 Move Nix files into a nix directory
Move everything from `config` to the root level.
2024-11-21 08:56:12 +00:00

14 lines
215 B
Nix

{
name = "_timer";
runtimeInputs = [ ];
text = ''
mins=$1
message=''${2:-Time out!}
sleep -- "$mins" * 60
notify-send -t 0 "''${message}" "Your timer of $mins min is over" -u normal
'';
}