dotfiles/nix/hosts/lemp11/hardware-configuration.nix
Oliver Davies af9edbfe1a Refactor NixOS and Home Manager modules
This makes them more modular and configurable by allowing features to be
enabled per-host.

Squashed commit of the following:

commit e9896d6166125de7aa26ddc63dac3adb196e8c23
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 23:06:23 2024 +0000

    Use mkMerge

    To ensure features isn't overridden and values aren't lost accidentally

commit c9c8ff5d059f08ade3aee9bb4e25bd51d4817a6d
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 22:56:38 2024 +0000

    Move NixOS module imports

commit 4a85bbac9dfa8f06825f6b1fee45ef27befa16d3
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 22:39:54 2024 +0000

    Move Home Manager module imports

commit 6d7a1b0aac68ccc8649fa2d8cd6e8b17ecebb4f0
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 21:15:54 2024 +0000

    Add host-specific Home Manager configurations

commit b32da2fbf7498c9684d8289be0f02800994e9110
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 18:00:00 2024 +0000

    Start to parameterise Home Manager modules

commit e80e89b415849cc4c6051a07b70587ac98724e2c
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 18:00:00 2024 +0000

    Rename wsl commands to home-manager

commit 6d82ed73da3c104fb25117fb843c3f3b5d833180
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 18:00:00 2024 +0000

    Refactor NixOS Home Manager configuration

commit cc5cbf5ac1a407a456d7258dd65a78ba3128a88f
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 08:05:00 2024 +0000

    Refactor WSL Home Manager configuration

commit deaf664a0997871b6f2bb0a8f97d638a91cb10bc
Author: Oliver Davies <oliver@oliverdavies.dev>
Date:   Mon Nov 25 08:04:00 2024 +0000

    Refactor lemp11 configuration
2024-11-26 08:13:46 +00:00

51 lines
1.6 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Do not modify this file! It was generated by nixos-generate-config
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
{
config,
lib,
modulesPath,
...
}:
{
imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
boot.initrd.availableKernelModules = [
"xhci_pci"
"thunderbolt"
"nvme"
"usb_storage"
"usbhid"
"sd_mod"
"sdhci_pci"
];
boot.initrd.kernelModules = [ ];
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
fileSystems."/" = {
device = "/dev/disk/by-uuid/e577c869-18a1-4830-9e00-124fcabdab89";
fsType = "ext4";
};
fileSystems."/boot/efi" = {
device = "/dev/disk/by-uuid/48FE-D346";
fsType = "vfat";
};
swapDevices = [ { device = "/dev/disk/by-uuid/2dce327b-f18d-4727-a9a2-e79d2b5161f9"; } ];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's
# still possible to use this option, but it's recommended to use it in conjunction
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
networking.useDHCP = lib.mkDefault true;
# networking.interfaces.enp0s13f0u1u2u4.useDHCP = lib.mkDefault true;
# networking.interfaces.wlp0s20f3.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
}