mirror of
https://github.com/opdavies/build-configs.git
synced 2025-01-22 18:27:31 +00:00
20 lines
542 B
Nix
20 lines
542 B
Nix
{
|
|
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-23.05";
|
|
|
|
outputs = inputs@{ flake-parts, ... }:
|
|
flake-parts.lib.mkFlake { inherit inputs; } {
|
|
systems = [ "x86_64-linux" ];
|
|
|
|
perSystem = { config, self', inputs', pkgs, system, ... }: {
|
|
devShells.default = pkgs.mkShell {
|
|
buildInputs = with pkgs; [ php82 php82Packages.composer ];
|
|
};
|
|
|
|
packages.default = pkgs.runCommand "default" { src = "./."; } ''
|
|
mkdir -p $out
|
|
cp ./build-configs $out
|
|
'';
|
|
};
|
|
};
|
|
}
|