22 lines
408 B
Nix
22 lines
408 B
Nix
{
|
|
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
|
|
outputs =
|
|
{ nixpkgs, ... }:
|
|
let
|
|
system = "x86_64-linux";
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
|
|
inherit (pkgs) mkShell;
|
|
in
|
|
{
|
|
devShells.${system}.default = mkShell {
|
|
buildInputs = with pkgs; [
|
|
nodejs
|
|
];
|
|
};
|
|
|
|
formatter.${system} = pkgs.nixfmt-rfc-style;
|
|
};
|
|
}
|